Back to overview
Downtime

Dashboard and Shares are unavailable

Nov 18 at 03:30pm CET
Affected services
Framebird App
API

Resolved
Nov 18 at 05:30pm CET

Cloudflare has mostly resolved the underlying routing issues related to their global outage, and their systems are now operating normally. With their network stabilized, the Better Stack UI and all related services are fully accessible again.

Created
Nov 18 at 03:30pm CET

We are currently experiencing an outage affecting both our Dashboard and Shares functionality. The root cause is an ongoing internal service degradation within the Cloudflare Global Network, our external hosting and network provider.
Cloudflare has reported that:
• They are experiencing an internal service degradation.

 • Some services may be intermittently impacted.

 • They are actively working to restore service and will provide further updates as remediation progresses.